Проект «SnakeProject» Михаила КозловаРегистрация

Навигация
⇒CISCO⇒

⇒ORACLE SQL \ JAVA⇒

⇐Voice(Asterisk\Cisco)
⇐Microsoft
⇐Powershell
⇐Python
⇐SQL\T-SQL
⇐FreeBSD and Nix
⇐1С
⇐Общая
⇐WEB Разработка
⇐Мото

CISCO: Настройка Virtual tunnel interfaces (VTI) VPN



Настройка Virtual tunnel interfaces (VTI) VPN

Рассмотрим замену стандартной реализации ipsec + gre

Дано:
Роутер 1 с адресом 1.1.1.1, гейтвеем "провайдера" 1.1.1.2
Роутер 2 с адресом 2.2.2.1, гейтвеем "провайдера" 2.2.2.2

Делаем политику по вкусу, задаем ключ и т.п.

crypto isakmp policy 1
 hash md5
 authentication pre-share
 lifetime 28800

crypto isakmp key Your_Secret_Key address 2.2.2.1

crypto ipsec transform-set Transform_Name esp-3des esp-md5-hmac

crypto ipsec profile VTI
 set transform-set Transform_Name

Интерфейсы петли, туннеля, внешний, влан:
 
interface Loopback0
 ip address 10.0.0.90 255.255.255.255

interface Tunnel0
 ip address 192.168.105.58 255.255.255.252
 ip ospf 10 area 0
 tunnel source 1.1.1.1
 tunnel destination 2.2.2.1
 tunnel mode ipsec ipv4
 tunnel checksum
 tunnel protection ipsec profile VTI

interface FastEthernet0
 ip address 1.1.1.1 255.255.255.240
 ip access-group 10 in
 ip virtual-reassembly
 duplex auto
 speed auto

interface Vlan19
 ip address 192.168.19.8 255.255.255.0
 ip ospf network broadcast
 ip ospf 10 area 0

Процесс OSPF, анонсируем через туннель сетку 192.168.19.0:
Это можно было и сделать статикой команды ip route
 
router ospf 10
 router-id 10.0.0.90
 log-adjacency-changes
 network 192.168.19.0 0.0.0.255 area 0

ip route 0.0.0.0 0.0.0.0 1.1.1.2

Извне трафик доступен только соседу(на внешке ip access-group 10 in)
access-list 10 permit 2.2.2.1


Комментарии пользователей

Эту новость ещё не комментировалиНаписать комментарий
Анонимам нельзя оставоять комментарии, зарегистрируйтесь!

© Snakeproject.ru создан в 2013 году. При копировании материала с сайта - оставьте ссылку.


Яндекс.Метрика

Goon Каталог сайтов Рейтинг@Mail.ru