Проект «SnakeProject» Михаила Козлова

Навигация

⇒ CISCO ⇐

Voice(Asterisk\Cisco)

Microsoft

Powershell

Python

SQL\T-SQL

FreeBSD and Nix

Общая

WEB Разработка

ORACLE SQL \ JAVA

Мото


CISCO VPN Site-to-Site


Приведу пример настройки vpn на cisco роутерах (в нашем случае 2911), проектировал данную задачу в cisco packet tracer, в боевом режиме на реальном оборудовании все работает.

Допустим есть у нас два роутера, и смотрят они в интернет, настроим vpn site-to-site между ними.

Для packet tracer активирована модель securityk9 на маршрутизаторах
R(config)# license boot module c2900 technology-package securityk9 
R(config)# end 
R# copy running-config startup-config 
R# reload

Роутер №1

Для начала определим интересующий нас трафик между двумя внутренними сетями за роутерами:

access-list 110 permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255

Настройка криптографической политики:

Маршрутизаторы перебирают политики начиная с 1й, стоит указать более стойкие политики перед слабыми

crypto isakmp policy 10

Алгоритм шифрования: AES 
encryption aes

Метод аутентификации: pre-share 
authentication pre-share

group 2
exit

Пропишем ключ (preshared key) для аутентификации нашим методом
crypto isakmp key cisco address 10.2.2.2

Методы шифрования и аутентификации

crypto ipsec transform-set VPN-SET esp-3des esp-sha-hmac
crypto map VPN-MAP 10 ipsec-isakmp
description VPN connection to R3

Укажем второй роутер, свяжем с методами шифрования и списком доступа

set peer 10.2.2.2
set transform-set VPN-SET
match address 110
exit

Свяжем с интерфейсом

interface S0/0/0
crypto map VPN-MAP

Роутер №2

access-list 110 permit ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255

crypto isakmp policy 10
encryption aes
authentication pre-share
group 2
exit
crypto isakmp key cisco address 10.1.1.2

crypto ipsec transform-set VPN-SET esp-3des esp-sha-hmac
crypto map VPN-MAP 10 ipsec-isakmp
description VPN connection to R1
set peer 10.1.1.2
set transform-set VPN-SET
match address 110
exit

interface S0/0/1
crypto map VPN-MAP


Комментарии пользователей

Эту новость ещё не комментировалиНаписать комментарий
Анонимам нельзя оставоять комментарии, зарегистрируйтесь!

Контакты для обмена ссылками между сайтами Видео к статьям на Youtube Сборник материалов по Cisco, Asterisk, Windows Server, Python и Django, SQL и T-SQL, FreeBSD и Linux Код обмена баннерами
Мои друзья: www.info-x.org - Информационный ресурс о ОС FreeBSD За сложными вещами простые действия Новости Ubuntu Linux Сообщество сисадминов Личный сайт skeletora Советы, помощь, инструменты для сис.админа, статическая и динамическая маршрутизация, FreeBSD

Рейтинг@Mail.ru
Рейтинг@Mail.ru Яндекс.Метрика

© Snakeproject.ru создан в 2013 году.
При копировании материала с сайта - оставьте ссылку.