Проект «SnakeProject» Михаила КозловаРегистрация

Навигация
⇒CISCO⇒

⇒ORACLE SQL \ JAVA⇒

⇐Voice(Asterisk\Cisco)
⇐Microsoft
⇐Powershell
⇐Python
⇐SQL\T-SQL
⇐FreeBSD and Nix
⇐1С
⇐Общая
⇐WEB Разработка
⇐Мото

Cisco GRE - со статическими роутмапами


Настройка GRE(разновидность VPN) туннеля.
В отличии от IPSec более прост и имеет меньше возможностей настройки.

 

Дано:

Первый маршрутизатор с внешним и внутренним интерфейсом:
R1  fa1/0 – 192.168.0.1/24 --- fa1/1 – 172.16.0.1/24  

 

Второй маршрутизатор с внешним и внутренним интерфейсом:

R2 fa1/0 – 192.168.1.1/24 --- fa1/1 – 172.16.1.1/24 

 

Маршрутизатор исполняющий роль интернета(соответственно у маршрутизаторов стоит шлюз по умаолчанию на маршрутизатор исполняющий роль интернета, у каждого на ip смотрящий в его сторону):

R3 fa1/0 – 192.168.0.2/24 --- fa1/1 – 192.168.1.2/24

 

Делаем настройку сначала на первом маршрутизаторе:

 

R1

R1#conf t

Создаем виртуальный интерфейс Tunnel с порядковым номером 1:

R1(config)#interface Tunnel1

Даем ему назначения откуда и куда будет идти туннель:

R1(config-if)#tunnel source 192.168.0.1

R1(config-if)#tunnel destination 192.168.1.1

Даем адрес в туннеле:

R1(config-if)#ip address 10.0.0.1 255.255.255.0

R1(config-if)#exit

Прописываем маршрут до локальной сети маршрутизатора-назначения через адрес маршрутизатора-назначения в туннеле:

R1(config)#ip route 172.16.1.0 255.255.255.0 10.0.0.2

Настраиваем второй маршрутизатор аналогично первому:

 

R2

R2#conf t

R2(config)#interface Tunnel1

R2(config-if)#tunnel source 192.168.1.1

R2(config-if)#tunnel destination 192.168.0.1

R2(config-if)#ip address 10.0.0.2 255.255.255.0

R2(config-if)#exit

R2(config)#ip route 172.16.0.0 255.255.255.0 10.0.0.1

Видео на канале YouTube: http://www.youtube.com/edit?o=U&video_id=InNWDnMxtGg

Скачать схему из PacketTracer: Схема


Комментарии пользователей

Эту новость ещё не комментировалиНаписать комментарий
Анонимам нельзя оставоять комментарии, зарегистрируйтесь!

© Snakeproject.ru создан в 2013 году. При копировании материала с сайта - оставьте ссылку.


Яндекс.Метрика

Goon Каталог сайтов Рейтинг@Mail.ru