Проект «SnakeProject» Михаила КозловаРегистрация

Навигация
⇒CISCO⇒

⇒ORACLE SQL \ JAVA⇒

⇐Voice(Asterisk\Cisco)
⇐Microsoft
⇐Powershell
⇐Python
⇐SQL\T-SQL
⇐FreeBSD and Nix
⇐1С
⇐Общая
⇐WEB Разработка
⇐Мото

Простая настройка EIGRP


Протокол EIGRP  является дистанционно-векторным, метрика вычисляется с помощью параметров delay,load,mtu,reliability,bandwidth.

Простая настройка протокола EIGRP на маршрутизаторе:

Войдем в конфигурирование маршрутизации протокола EIGRP присвоив ему номер автономной сети, по которому маршрутизаторы будут понимать, кто будет обновляться(исчисление идет с номера 100):

Router#router EIGRP 200

Укажем сети, которую маршрутизатор будет транслировать в другие сети:

Router#network 192.168.0.0 255.255.255.0

Router#network 172.16.0.0 255.255.255.0

Отключение автоматического суммирования(необходимо, если для смежных подсетей назначены разные интерфейсы):

Router#no auto-summary

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Пример настройки:

Настрока на интерфейсе в сторону соседского роутера:
R1(config)#interface serial 0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#description For_R2
R1(config-if)#no shutdown

Настрока на интерфейсе в сторону внутренней сети:
R1(config-if)#interface fa 0/0
R1(config-if)#ip address 172.16.10.1 255.255.255.0
R1(config-if)#description For_local
R1(config-if)#no shutdown
R1(config-if)#exit

Настройка EIGRP (100 - логический сегмент(номер автономной сети), у соседа должен быть идентичен, возможана другая нумерация, например 101, 224 и другие):
R1(config)#router eigrp 100
Выключим автосуммаризацию сетей (пример есть сети 192.168.10.1/24, 192.168.3.1/24, 192.168.22.1/24, для общей раздачи одной строкой network 192.168.0.0 255.255.0.0):
R1(config-router)#no auto-summary
R1(config-router)#network 172.16.10.0 255.255.255.0
R1(config-router)#exit

Настройка аутентификации:
Создадим связку ключей, название необязательно задавать идентичное на разных роутерах:
R1(config)#key chain MyChain
Привяжем ключи к связке, номера необязательно задавать идентичными:
R1(config-keychain)#key 10
R1(config-keychain-key)#
Задаем ключи, они должны быть идентичными у соседей:
R1(config-keychain-key)#key-string gh^&45Ca
R1(config-keychain-key)#
R1(config-keychain)#key 20
R1(config-keychain-key)#key-string ^qQwd!1
R1(config-keychain-key)#exit

Включаем аутентификацию EIGRP на интерфейсе для сегмента 100:
R1(config)#interface serial 0/0
R1(config-if)#ip authentication mode eigrp 100 md5
R1(config-if)#ip authentication key-chain eigrp 100 MyChain

--------------------------------------------------------------------------------------
По аналогии у соседа:
R2(config)#int serial 0/0
R2(config-if)#ip address 192.168.10.2 255.255.255.0
R2(config-if)#description For_R1
R2(config-if)#no shutdown

R2(config)#interface fa 0/0
R2(config-if)#ip address 172.16.20.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#router eigrp 100
R2(config-router)#no auto-summary
R2(config-router)#network 172.16.20.0 255.255.255.0
R2(config-router)#exit

R2(config)#key chain MyChain
R2(config-keychain)#key 10
R2(config-keychain-key)#
R2(config-keychain-key)#key-string gh^&45Ca
R2(config-keychain-key)#
R2(config-keychain)#key 20
R2(config-keychain-key)#key-string ^qQwd!1
R2(config-keychain-key)#exit

R2(config)#interface serial 0/0
R2(config-if)#ip authentication mode eigrp 100 md5
R2(config-if)#ip authentication key-chain eigrp 100 MyChain

Команды для вывода информации:

show ip eigrp neighbor

show ip eigrp topology

show ip eigrp interface

show key chain MyChain


Комментарии пользователей

Эту новость ещё не комментировалиНаписать комментарий
Анонимам нельзя оставоять комментарии, зарегистрируйтесь!

© Snakeproject.ru создан в 2013 году. При копировании материала с сайта - оставьте ссылку.


Яндекс.Метрика

Goon Каталог сайтов Рейтинг@Mail.ru