Проект «SnakeProject» Михаила КозловаРегистрация

Навигация
⇒CISCO⇒

⇒ORACLE SQL \ JAVA⇒

⇐Voice(Asterisk\Cisco)
⇐Microsoft
⇐Powershell
⇐Python
⇐SQL\T-SQL
⇐FreeBSD and Nix
⇐1С
⇐Общая
⇐WEB Разработка
⇐Мото

Cisco 811 проброс портов


Как просто пробросить порт, например RDP

Есть машина в локальной сети и внешний адрес на роутере, нам поможет static nat

1.1.1.2 в нашем случае играет роль внешнего адреса.

1.1.1.1 адрес провайдера

Показано на примере Cisco 881

Внутренний интерфейс:

ofrouter#(config)# int fa0/0
ofrouter#(config-if)# ip nat inside

Внешний интерфейс:

ofrouter#(config)# int fa1/0
ofrouter#(config-if)# ip nat outside

Трансляция одного адреса без указания порта:

ofrouter#(config)# ip nat inside source static 192.168.10.20 1.1.1.2

Трансляция между интерфейсом и адресом:

ofrouter#(config)# ip nat inside source static 1.1.1.2 int fa0/0

Трансляция на примере RDP:

ip nat inside source static tcp 192.168.10.20 3389 1.1.1.2 65020 extendable

А вот и пример настройки Cisco 881 для маленького офиса, динамический nat пропускает пользователей в интеренет, статический транслирует RDP подключение из вне.

ofrouter#sh run
Building configuration...

Current configuration : 1716 bytes
!
! Last configuration change at 11:00:42 UTC Wed May 4 2016 
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ofrouter
!
boot-start-marker
boot-end-marker
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
aaa session-id common
memory-size iomem 10
!
ip domain name office
ip cef
no ipv6 cef
!
!
ip ssh version 1
csdb tcp synwait-time 30
csdb tcp idle-time 3600
csdb tcp finwait-time 5
csdb tcp reassembly max-memory 1024
csdb tcp reassembly max-queue-length 16
csdb udp idle-time 30
csdb icmp idle-time 10
csdb session max-session 65535
!
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 ip address 1.1.1.2 255.255.255.252
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Vlan1
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 10 interface FastEthernet4 overload
ip nat inside source static tcp 192.168.10.20 3389 1.1.1.2 65020 extendable
ip route 0.0.0.0 0.0.0.0 1.1.1.1
!
access-list 10 permit 192.168.10.0 0.0.0.255
!
line con 0
 no modem enable
line aux 0
line vty 0
 transport input all
line vty 1 4
 transport input ssh
!
!
end


Комментарии пользователей

Эту новость ещё не комментировалиНаписать комментарий
Анонимам нельзя оставоять комментарии, зарегистрируйтесь!

© Snakeproject.ru создан в 2013 году. При копировании материала с сайта - оставьте ссылку.


Яндекс.Метрика

Goon Каталог сайтов Рейтинг@Mail.ru